Get the latest news about PS4 at and Xbox One at!

Some players still reporting 2.1 update hasn’t fixed connection issues in Splatoon


The 2.1.0 patch for Splatoon is now live and while it brought about many bug and glitch fixes, the major issue it was designed to address still seems to be a problem for several people. The August update brought about some netcode changes and now people are experiencing getting dropped within 30 seconds of any match they join. One frustrated neoGAFer notes that it’s happening much more frequently now.

Are we sure Nintendo knows about this issue? I’ve had a look around and it feels like there are just a handful of EU players complaining about this

I tried again last night, got kicked from all 3 matches I started after 30 seconds to one minute, then switched to MK8 and had no issues

MK8 I’ve never had issues with, and Splatoon was fine as well for the first 55 hours I played it, it’s only since 2.00 it’s been a mess

Before 2.00 I’d get kicked out of maybe 1 match every 20, whereas now it’s every single match

It’s a shame because the game is fantastic, but ultimately unplayable for me now, and it’s been over a week and we’re heard nothing from Nintendo

It should be noted that the player base currently experiencing this error seems to be rather small and Nintendo might be having trouble pinpointing the issues for these players after the update. No matter whether the Wii U is connected wirelessly or hardwired, people are still reporting connection issues within the game.

How has your connection been since the latest update?

Continue reading:

TAGS: , ,